oil sensor leaking

Post Reply
User avatar
schrader7032
Posts: 7231
Joined: Fri Oct 27, 2006 3:00 am

oil sensor leaking

Post by schrader7032 »

Michal -

The oil filter's on the right side...the oil level (really the pressure) sensor is on the left side. I can't see that the new leak at the sensor has anything to do with the oil change. I think it's "just bad timing". These sensors go bad after a while and leak just like you're talking about...right through the middle. Before you consider changing it, clean everything real well, and dust the area with baby powder or talcum. Then go for a ride or two. Monitor where the oil drip starts from. Just to be sure it is indeed the sensor.

Changing it is no big deal...lean the bike over the to the right side, take out the old one, insert the new one. Don't over tighten the new sensor...that can break the center portion and you're back where you started.

Parts source? You're in Sunnyvale, CA, right? I'd say look up Ted Porter at the Beemershop - http://www.beemershop.com. He knows Airheads inside and out and can give you words of advice.

I've been using about 3-4 books for my /7. I have a very old Clymer that serves now as my on-bike manual for trips. I tend to look a lot at my most recent Haynes...lots of pictures. A believe Clymer has newer versions. Might check with Ted and see what he recommends. It's probably a good idea to get at least a couple so you can bounce them off each other and make sure things make sense. All of the books have some errors in places...even BMWs shop manuals. So, it's good to check and double check on torques, specs, etc.

Kurt in S.A.
Kurt in S.A.
'78 R100/7 '69 R69S '52 R25/2

lati_cz
Posts: 1
Joined: Sun Mar 15, 2009 2:05 pm

thanks Kurt

Post by lati_cz »

Thanks for quick respond. I doubted it was related to the oil change, the timing made me “think”. It is the sensor, it’s leaking right trough the middle. I pulled the sensor out – I was able to blow through. It went bad. Thanks for the guidance, I feel better. I really appreciate it.

User avatar
VBMWMO
Posts: 1322
Joined: Sun Aug 23, 2009 7:49 pm

oil sensor leaking

Post by VBMWMO »

Hello everyone,
I bought 1974 R60/6 few weeks ago. I changed the oil and filters, put maybe 50 miles after with no problem. Now I noticed there is oil dripping from oil lever sensor, the leak is between the aluminium nut and the plastic insert. Does it have to do anything with the oil change? Or the level sensor just went bad? The oil level is where supposed be, the bike is running like before. I changed the oil for first time, followed the manual, didn’t see any problems. Just want to make sure I did it correctly. If the problem is the sensor, is there good source for parts?
What’s the best book about maintaining R60/6?
Thanks Michal
Dedicated to the Preservation of Classic and Antique BMW Motorcycles.

Post Reply