1977 R100RS Instrument Cluster mismatch

User avatar
kingcowie
Posts: 28
Joined: Wed Oct 28, 2020 1:29 pm
Location: Wollongong

Re: 1977 R100RS Instrument Cluster mismatch

Post by kingcowie »

srankin wrote:
Tue Nov 17, 2020 7:01 pm
BMW, equals Bite My Wallet, LOL. this looks like the correct part, and it is in darn good shape. From what my Mate in Melbourne tells me, the cost of things in AU is a lot higher than here in the US. Looking at the price being asked, and knowing the cost of stuff in AU. I think the price is reasonable.

One thing you might want to make sure of is that it is from an R100RS. The reason I say this is because of what I mentioned in a previous posting about the speedometer having to match the final drive ratio. The letter and number combination at the bottom of the speedometer (W=691) gives a reference number for the gearing in the speedometer in conjunction with the numbers stamped on the final drive for gear ratio.

I am afraid I don't have a cross reference for metric speedometers, so I can't say for sure the speedometer matches with your final drive. IF the R80 bike AND the 78RS both have the same final drive gear ratio, it would be safe to say this is the correct speedometer.

OKAY, I wrote a lot about the speedometer, despite the speedometer, the cluster itself is correct for your bike. This will I hope, solve the electrical problems. I think it is safe to say the speedometer matches and there will not be a problem there.
If there is, that can be dealt with later and is not a show stopper. St.
Will do thanks.
Shane
Wollongong, Australia
71 R75/5
64 R50/2 Project
77 R100RS Project

Post Reply