If you like our site, please consider joining our club!
By joining you will help ensure that we can continue to provide this service
JOIN HERE!

64 R50 generator problem

johnab9hh@att.net
Posts: 3
Joined: Mon Nov 08, 2021 9:13 am

64 R50 generator problem

Post by johnab9hh@att.net »

I've had multiple gen problems.
My red light started flashing on. I found that the brushes were worn to the end.
I ordered a new set from MAX. after the third type shipped to me, i had a set that fit. They were hanging up in the carrier a little bit, so i sanded slightly with emery cloth, then cleaned the brushed and carriers with alcohol on swabs.
The light then went out.
When I would run the engine up to about 3k rpm (guessing) it would open the fuse to the battery. 
I put my good fluke meter to measure voltage. about 7.2 volts steady.
I put my good fluke dc ammeter on, about 2.8 amps, steady.
When I slowly would it up, everything was steady, then POP, the fuse to battery plus would open. I could not record the peak.
I looked for corrupted wiring, since I was in there, but found none. 
I have a new voltage regulator, from Vech's old stock at Max, but I don't want to throw parts at it. I'm not that type of guy. 
Ive read the Doug Rinckes manual, but it seems lacking in this area.
Thank you for your time

User avatar
wa1nca
Posts: 1061
Joined: Thu Sep 27, 2012 5:15 pm
Location: Ashfield Ma

Re: 64 R50 generator problem

Post by wa1nca »

Fuse size ?
Tommy Byrnes
54 R51/3 55 R50/Velorex 560 sidecar 64 R27 68 R69US 75 R75/6
Ashfield, Ma
USA

User avatar
vechorik1373
Posts: 177
Joined: Fri Oct 27, 2006 3:00 am

Re: 64 R50 generator problem

Post by vechorik1373 »

I agree, what amp fuse do you have installed? It may not be heavy enough.
Vech
Technical Adviser, Former owner, Bench Mark Works
662 312 2838 cell 9 am to 4pm CST PLEASE!

johnab9hh@att.net
Posts: 3
Joined: Mon Nov 08, 2021 9:13 am

Re: 64 R50 generator problem

Post by johnab9hh@att.net »

20 amp, and it makes an audiable POP
Any Clue?

User avatar
wa1nca
Posts: 1061
Joined: Thu Sep 27, 2012 5:15 pm
Location: Ashfield Ma

Re: 64 R50 generator problem

Post by wa1nca »

Charging reading look good
20 amp fuse also good
Seems like a short somewhere in wiring harness
1st
When key is down terminal 15/54 is hot
power to :
disconnect one wire at a time
Horn
Stop light switch
neutral light switch
red charge light
directional flasher
2nd
key down turned for taillight
check tail light bulb and circuit
running light in headlamp
3r d
key down turned for headlight
check headlight circuit
Tommy
Tommy Byrnes
54 R51/3 55 R50/Velorex 560 sidecar 64 R27 68 R69US 75 R75/6
Ashfield, Ma
USA

User avatar
vechorik1373
Posts: 177
Joined: Fri Oct 27, 2006 3:00 am

Re: 64 R50 generator problem

Post by vechorik1373 »

I agree, 20 amp is a big fuse for the bike. You have a DEAD short to ground somewhere.
Vech
Technical Adviser, Former owner, Bench Mark Works
662 312 2838 cell 9 am to 4pm CST PLEASE!

johnab9hh@att.net
Posts: 3
Joined: Mon Nov 08, 2021 9:13 am

Re: 64 R50 generator problem

Post by johnab9hh@att.net »

Thanks for the tips. Ill start checking. But its odd that this started IMMEDIATELY after replacing the brushes.
Also Tommy, de AB9HH 73

User avatar
wa1nca
Posts: 1061
Joined: Thu Sep 27, 2012 5:15 pm
Location: Ashfield Ma

Re: 64 R50 generator problem

Post by wa1nca »

de AB9HH 73
Ham ?
Tommy Byrnes
54 R51/3 55 R50/Velorex 560 sidecar 64 R27 68 R69US 75 R75/6
Ashfield, Ma
USA

User avatar
schrader7032
Posts: 8444
Joined: Fri Oct 27, 2006 3:00 am
Location: San Antonio, TX

Re: 64 R50 generator problem

Post by schrader7032 »

wa1nca wrote:
Wed Dec 07, 2022 7:02 pm
de AB9HH 73
Ham ?
Look it up!!

https://wireless2.fcc.gov/UlsApp/UlsSea ... icense.jsp
Kurt in S.A.
'78 R100/7 '69 R69S '52 R25/2
Fast. Neat. Average. Friendly. Good. Good.

User avatar
wa1nca
Posts: 1061
Joined: Thu Sep 27, 2012 5:15 pm
Location: Ashfield Ma

Re: 64 R50 generator problem

Post by wa1nca »

tnx Kurt
John 73
Amateur Extra Class
_.. . wa1nca
Tommy Byrnes
54 R51/3 55 R50/Velorex 560 sidecar 64 R27 68 R69US 75 R75/6
Ashfield, Ma
USA

Post Reply