3 replies [Last post]
ThompsonJP
ThompsonJP's picture
 Offline
Vancouver, Wash.
Joined: 05/22/2014
Posts: 12

Hey, I have an intermittent problem with my 74 R90/6 that just cropped up. It has a Dyna III electronic ignition that is probably five years old.
Several times in the past month, I haven't been able to even get the dial lights to come up when trying to start. This morning, the bike cut out a block from home and wouldn't restart or light up the gauges.
I've checked the battery; it's newer and kept on a charger. I've checked the ground and it's secure and just like it always has been. When I can get the dials to light up and press the ignition, I'll get one click from under the tank and then nothing. I can bump start it.
Any ideas where I can look next?
Thank you, the sun's finally coming on in the Pacific NW and I want to get out there.

schrader7032
schrader7032's picture
 Offline
VBMWMO #7032
San Antonio, TX
Joined: 10/27/2006
Posts: 6327
Sometimes they say starting

Sometimes they say starting problems are 90% battery issues...wouldn't hurt to get the battery load tested. I bought a new battery from BMW for my /7 and after only a few starts began to have issues with starting and getting it charged. Took it back...dead cell...got a new battery.

Could also be the starter relay. When you get the clicking, what do you read across the battery terminals? If the voltage doesn't change, reads only say 12.5v, then something is wrong with the relay. If the voltage drops to well below 10v, then it's the battery.

For the relay, find it along the left side of the frame under the tank and unplug it and replug a few times. Could be corrosion on the terminals.

__________________

Kurt in S.A.
'78 R100/7 '69 R69S '52 R25/2

ThompsonJP
ThompsonJP's picture
 Offline
Vancouver, Wash.
Joined: 05/22/2014
Posts: 12
Problem solved

Boy, do I feel silly and lucky. It was a slightly loose ground at the battery terminal. Thanks for the comments. Now I know where my starter relay is.

RickR90s
RickR90s's picture
 Offline
Farmington Hills, MI
Joined: 11/28/2016
Posts: 63
Intermittent starter

I was going to suggest looking at the ignition switch also. Lots of Airhead owners never think of a 40+ year old switch being the problem. Smile

Glad you got it figured out.

__________________

RickR90s

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.