6 replies [Last post]
Guaire
Guaire's picture
 Offline
Arlington, VA
Joined: 08/16/2016
Posts: 33

I sent my meters in for overhaul. Everything was working except the main odometer and the trip meter. The speedo was running 3 to 4 mph high. Not bad though. Tach is ok. Shipped the whole thing to North Hollywood Speedometer. The pic is what the cockpit looks like with the meter housing.

  • no_meters.jpg
__________________

1983 R80RT, 2014 Royal Enfield Continental GT, 1986 Honda VF500F

wolds
wolds's picture
 Offline
VBMWMO #8011
Joined: 11/08/2010
Posts: 100
Please keep us posted with

Please keep us posted with the progress of your project. I contacted Frank from NHS about a similar project on my R60/6 including getting the faces and pointers replaced but he didn't get back to me with pricing yet. This all started when I read the post from the the guy that makes the LED circuit boards for illumination. I'll probably send mine out next month. Warren

__________________

2007 BMW R1200RT
1979 Yamaha XS650 "cafe"
1976 BMW R90S
1976 BMW R60/6

schrader7032
schrader7032's picture
 Offline
VBMWMO #7032
San Antonio, TX
Joined: 10/27/2006
Posts: 6540
The trip meter not working is

The trip meter not working is something that comes up from time to time. For the /6/7-style speedometers, there's a relatively easy fix that involves a spot of glue at the end of the shaft to keep the gears together.

The speedometers left the factory with a slight over reading of the speed...there's a service bulletin that addresses that. Basically, BMW didn't want their instrument to read a lower speed than the bike was actually doing...then the rider would get a ticket. The tendency to read higher covers to some degree some of the variables that could affect speed. Using the wrong tires can result in improper readings.

__________________

Kurt in S.A.
'78 R100/7 '69 R69S '52 R25/2

Guaire
Guaire's picture
 Offline
Arlington, VA
Joined: 08/16/2016
Posts: 33
Yesterday I got an email

Yesterday I got an email telling me that my package had been delivered. Last night I got a call from NHS. I described the Speedo as ok, as it reads 3-4 mph high. I think that is well within spec for a speedo. I've seen worse! I told our man that the trip meter and the odometer were the problems. Tach is ok. Looks like I'm good to go into the service queue. The "courtesy call" was a very decent thing to do. Progress and communication are cool.

__________________

1983 R80RT, 2014 Royal Enfield Continental GT, 1986 Honda VF500F

Guaire
Guaire's picture
 Offline
Arlington, VA
Joined: 08/16/2016
Posts: 33
4 weeks from the day of the

4 weeks from the day of the package getting to NOHO.

__________________

1983 R80RT, 2014 Royal Enfield Continental GT, 1986 Honda VF500F

Guaire
Guaire's picture
 Offline
Arlington, VA
Joined: 08/16/2016
Posts: 33
Today I heard from No Ho

Today I heard from No Ho Speedo. My meters will be getting shipped back to me. My bill, including shipping, was $211.
Now I get to keep an eye on the mailbox and the thermometer. Temps will be getting back up to a good riding temp.

__________________

1983 R80RT, 2014 Royal Enfield Continental GT, 1986 Honda VF500F

Guaire
Guaire's picture
 Offline
Arlington, VA
Joined: 08/16/2016
Posts: 33
I just received the renewed

I just received the renewed meters from NHS. The meter faces and needles look brand new.Now I have to get over my Spring cold. I'm doing part time work Wed to Friday. But, it won't take long to get the instrument panel connected.
Once I do that, I will add on the Eastern Beaver fuse box 8. Then I can get on my 12v utility socket, the Garmin and the two zone Gerbings heater connections.

__________________

1983 R80RT, 2014 Royal Enfield Continental GT, 1986 Honda VF500F

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.